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INTRODUCTION
The Semblance plug-in is used to pick velocity-time pairs and ETA-time pairs based on hyperbolic searches for
coherence between multiple seismic signals in migrated gathers. The goal of this utility is to provide a robust velocity
analysis to aid in further iterations of migration. In Tsunami’s Semblance Builder, the user is capable of picking both
RMS and ETA semblance simultaneously, with instantaneous on-screen updates of the flattened gathers. With the
Semblance utility, the user can choose to output an RMS velocity model and/or an ETA model of interpolated
Semblance picks.
To access this help file at any time, press F1 with an active Semblance Session.

SETUP

OPENING GATHERS
Semblance Builder requires a set a migrated gathers and an RMS velocity model. If the gathers were migrated using
an ETA model, the ETA model used must also be supplied. The migrated gathers can be 3D (indexed by INLINE, XLINE,
and Offset) or 2D (indexed by XLINE and Offset). The associated RMS velocity model must be rectangular (each INLINE
has the same number of XLINEs) and be indexed in 3D (INLINE and XLINE) or 2D (XLINE). The associated ETA model (if
used) must be rectangular (each INLINE has the same number of XLINEs) and must be indexed in 3D (INLINE and XLINE)
or 2D (XLINE).
•

See INTViewer’s tutorial on indexing for more information and options.

Once indexed, the gathers are loaded into the INTViewer by selecting File->Open Data in New XSection Window>Seismic...
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Alternatively, the user could open the migrated gathers by clicking the Directory button below the file menu.

When the properties menu is displayed, select one gather to be used to build the first semblance by restricting the
inline and xline range. Select the increment you wish to pick in both the INLINE and XLINE directions.

Time Semblance
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In the picture example, the first gather selected is INLINE 450, XLINE 700. When Semblance starts, it will pick on every
10th INLINE and every 15th XLINE.
The user could change the picking increment at any time during the Semblance picking session by selecting the input
gathers layer, then right click to bring up the properties menu.
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In order to start the plug-in, the indexed gathers must be open and made an active layer. Open the Semblance plugin panel, by navigating to the Tsunami tool bar -> Velocity -> Semblance Builder. Upon opening data used for the first
time, the “Scanning gather boundaries” dialog box will pop up. The larger the input gathers, the longer it takes to
initialize the file, but generally it renders at a rate of 8000 CDPs/min. This is only done once, as long as the user has
permissions on the .pec files created in the application directory (the directory that contains the input gathers).

Time Semblance
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This is the Semblance panel on start-up. Supply the relevant parameters and press OK to start the RMS and/or ETA
picking session. Opening/Saving Parameter files
Once happy with your parameters, the user can save the parameters by right- clicking the Semblance panel and
clicking Save As.
To open a saved parameter file, right-click the Semblance panel and click Open. For more information on using the
parameters, see Using Semblance
For a comprehensive description of Semblance parameters see Appendix.
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SCALING
For ease of use, set the horizontal and vertical scaling parameters by going to Plot > Scale. Changing the scaling of any
of the Semblance panels (gathers, RMS semblance, and/or ETA semblance) will broadcast the scaling changes to all
open panels.

To automatically fit the scaling to the size of your open INTViewer window sessions, press F5. It will split the available
room evenly between the open Semblance panels.
Color adjustment window
To better focus the Semblance coherency clouds, user can change the color mapping scale.
1.
2.
3.

Click the RMS or ETA Semblance window to make it an active layer.
Then click the Color Adjust Window on the side panel.
Change the minimum and maximum amplitude values to focus the Semblance’s coherency.

If you do not like the color mapping, press Reset to Default and continue adjusting until comfortable with the
Semblance color map.
The user is now ready for Semblance picking.
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PICKING RMS & ETA SIMULTANEOUSLY
1.
2.

Supply an indexed RMS velocity model
If used, supply an indexed ETA model.
a. Note, the input gathers must have ETA applied in order to use this feature
3. If using floating datum, supply a trace.db
a. Specify if the Seismic and Velocity is either at Final Datum or Floating Datum
b. Supply a reference velocity if Seismic and Velocity is at Final Datum
c. If there is a mismatch between the Seismic and Velocity model datum, use Tsunami’s Floating
Datum Utility to adjust the Seismic and Velocity to the same datum
4. Select “Remove NMO” from gathers
5. Select the “Vary by Range” radio button
6. Set the RMS Velocity Range. The fields will be populated with the limits of the RMS model.
a. Tsunami advises to make the RMS Velocity range slightly larger than the dimensions of the input
RMS model
b. The [(Velocity Max – Velocity Min)/ Velocity Increment] = Velocity Step.
i. The Velocity step cannot exceed 200
c. The smallest velocity increment that can be used is 20 [distance/time] units
7. Set the ETA Limits. The fields will be populated with the dimensions of the provided ETA model, if used.
a. Tsunami advises to make the ETA Limits slightly larger than the dimensions of the input ETA
model
b. The [(ETA max- ETA min)/ ETA increment] = ETA Step
i. The ETA step cannot exceed 200
c. The smallest ETA increment that can be used is 0.001
8. Provide the INLINE and XLINE distance. This is also known as the INLINE and XLINE spacing, which will be
used to interpolate the output Semblance models.
9. Press OK to start Semblance picking. Three screens will open to the screen; the input gathers with NMO
preview applied, the RMS semblance panel, and the ETA semblance panel.
10. Navigate through the gathers, picking until finished with your velocity analysis.
11. It is generally advisable to make RMS picks before updating your ETA picks. Any new picks to the RMS
Semblance panel will update the ETA coherency clouds.
12. To output pick files or output RMS and/or ETA models see the Output Data section

Time Semblance
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PICKING RMS AL ONE
1.
2.

Supply an indexed RMS velocity model
If used, supply an indexed ETA model.
a. Note, the input gathers must have ETA applied in order to use this feature
3. If using floating datum, supply a trace.db
a. Specify if the Seismic and Velocity is either at Final Datum or Floating Datum
b. Supply a reference velocity if Seismic and Velocity is at Final Datum
c. If there is a mismatch between the Seismic and Velocity model’s datum, use
Tsunami’s Floating Datum Utility to adjust the Seismic and Velocity to the
same datum
4. Select “Remove NMO from gathers”
5. Select the “Vary by range” radio button
6. Set the RMS Velocity Range. The fields will be populated with the limits of the RMS
model.
a. Tsunami advises to make the RMS Velocity range slightly larger than the
dimensions of the input RMS model
b. The [(Velocity Max – Velocity Min)/ Velocity Increment] = Velocity Step.
i. The Velocity step cannot exceed 200
c. The smallest velocity increment that can be used is 20 [distance/time]
7. Set the ETA Limits to be blank.
8. Provide the XLINE and/or INLINE distance. This is also known as the INLINE and XLINE
spacing, which will be used to interpolate the output Semblance models.
9. Press OK to start Semblance picking. Two panels will open to the screen; the input
gathers with NMO preview applied and the RMS semblance panel.
10. Navigate through the gathers, picking until finished with your velocity analysis.
11. To output RMS pick files or output RMS models see the Output Data section

PICKING ETA AL ONE
1.
2.
3.

Supply an indexed RMS velocity model
If used, supply an indexed ETA model.
a. Note, the input gathers must have ETA applied in order to use this feature
If using floating datum, supply a trace.db
a. Specify if the Seismic and Velocity is either at Final Datum or Floating Datum
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b.
c.

Supply a reference velocity if Seismic and Velocity is at Final Datum
If there is a mismatch between the Seismic and Velocity model’s datum, use Tsunami’s Floating
Datum Utility to adjust the Seismic and Velocity to the same datum
4. Make sure “Remove NMO from gathers” is not selected
5. Select the “Vary by range” radio button
6. Set the RMS Velocity Range to be blank.
7. Set the ETA Limits. The fields will be populated with the dimensions of the provided ETA model, if used.
a. Tsunami advises to make the ETA Limits slightly larger than the dimensions of the input ETA
model
b. The [(ETA max- ETA min)/ ETA increment] = ETA Step
i. The ETA step cannot be less than 200
c. The smallest ETA increment that can be used is 0.001
8. Provide the XLINE and/or INLINE distance. This is also known as the INLINE and XLINE spacing, which will
be used to interpolate the output Semblance models.
9. Press OK to start Semblance picking. Two panels will open to the screen; the input gathers with NMO
preview applied and the ETA semblance panel.
10. Navigate through the gathers, picking until finished with your velocity analysis.
11. To output ETA pick files or output ETA models see the Output Data section

Continue picking with previous picks files
1.
2.
3.

4.

Supply an indexed RMS velocity model
If used, supply an indexed ETA model.
a. Note, the input gathers must have ETA applied in order to use this feature
If using floating datum, supply a trace.db
a. Specify if the Seismic and Velocity is either at Final Datum or Floating Datum
b. Supply a reference velocity if Seismic and Velocity is at Final Datum
c. If there is a mismatch between the Seismic and Velocity model’s datum, use Tsunami’s Floating
Datum Utility to adjust the Seismic and Velocity to the same datum
To use pick files from 3rd Party sources
a. Click the “Convert ASCII file to semblance Pointset file” to convert Promax or .xml files to

Time Semblance

Page | 12

TSUNAMI TECHNICAL MANUAL

b.
c.
d.
e.
f.

5.
6.
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compatible pointsets.
Select Semblance field key type to ETA or Velocity from the drop down menu
Skip any initial lines, if necessary
Select the column in which the INLINE, XLINE, offset, velocity/ETA, and time pairs are kept. The
column will be highlighted by the correlating color for ease of use.
Once appropriate columns are named, select the unit of time used in the pointset to be
milliseconds or seconds.
Select OK to name and save the pointset.

To use pick files from previous Semblance sessions
a. The .aps or .xps files saved from INTViewer are compatible with Semblance and
do not need conversion
In the “Saved Picks” field, browse to find the picks file used from a previous session. The
user can select both the RMS and ETA picks files by selecting “Ctrl” and highlighting both
files from the open dialog box
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7.
8.
9.

Select the “Vary by range” radio button
Select “Remove NMO from gathers”
Set the RMS Velocity Range, ETA Limits, and INLINE/XLINE distance parameters and
press OK
10. Navigate to a gather picks exists on; a black line with previous Semblance picks
will be drawn on the corresponding Semblance panels

COPYING PICKS
Picks can be copied from the nearest gather by clicking the middle mouse button, also known as the scroll wheel. If
picks exists on any gather, the user can copy picks to the current gather.
ADJUSTING/DELETING PICKS
To move a pick, hover over a point until you see the highlighted target circle. Drag and drop the point to anywhere on
the Semblance panels.
To delete a pick, hover over a point until you see the highlighted target circle. Click the middle mouse button, also
known as the scroll wheel, to delete the pick.
NAVIGATING THE GATHER S
The INLINE, XLINE, and offset headers will be displayed at the top of each Semblance panel.

Time Semblance
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The picking increments used by Semblance are the INLINE and XLINE increments used to define the display properties
at start-up. Clicking Next or Previous INLINE or XLINE will move up or down an INLINE or XLINE based on this
increment. The user is free to traverse the input gathers in any direction, backwards or forwards.
Change the INLINE or XLINE picking increment at any time during the Semblance session, by clicking the gathers
window to make it an active layer, right click properties, and changing the INLINE or XLINE increment.
To navigate the gathers, the user may also enter any value in the XLINE and/or INLINE “Jump to” fields, as long as it
exists. If the INLINE or XLINE number used does not exist, Semblance will round to the nearest gather available. Hover
over the “Jump to” fields with your mouse cursor to get the dimensions of the input dataset for easier navigation.
LINE OVERLA YS
If picks exists on any gather to the left or to the right of the currently selected gather on the same inline, a QC line
overlay could be used to guide picking.

In the picture example, picks exists on (il 450, xl 710) and (il 450, xl 720). Sandwiched in between is gather (il 450, xl
715). The Previous Picks (the light blue line) overlay outline picks from gather (il 450, xl710) while the Next Picks (the
pink line) overlay displays picks from gather (il 450, xl 720). Both can be used to guide picking, but do not affect the
current picks made on the gather.
This only works for gathers to the immediate right or left of the current gather.
Closing and restarting a Semblance session
If closing an RMS or ETA Semblance window, all other windows must close to clear the cache for future Semblance
sessions. The user will be prompted with the following dialog box, to ensure closing the panels are the intended action.
Time Semblance
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SAVING THE OUTPUT FILES
To save the output files perform these steps:
1. Click the side Semblance Window button
2. Click the Output Data: Create Velocity Models button
3. Click to output a Semblance RMS model, an ETA model, or both
a. Click the radio button for the interpolation method prefered, Linear or Inverse Distance
Weighting
4. Wait for the models to render, the models will output to the screen
5. Select the file and right click to go to the properties menu.
6. In the range field please put an asterisk ( * ) in all fields to include the complete range
of data. Not doing so will only save the default, selected INLINE.
7. Save the seismic by going to File--> Save Seismic Data. The segy output of the RMS and
ETA volumes can be used directly into Tsunami Migration.
a. For further QC or gather conditioning with Tsunami tools, users can also
save the indexed output by selecting index files from the drop down menu
SAVING THE PICKS FILES
To save the velocity-time and/or ETA-time picks perform these steps:
1.
2.
3.

Select the RMS or ETA Semblance window to make the window an active layer
Click File -> Save Pointset
Follow the dialog box instructions for naming of pointset files. Choose to save it as either an .aps file or an
.xps file, both of which are compatible in future picking sessions of Semblance.
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APPENDIX
PARAMETERS

STARTING SEMBLANCE PANEL
FILES
•
•
•
•
•
•

Seismic dataset: Input migrated gathers indexed in 2D (xline, offset) or 3D (inline, xline, offset)
Velocity model: RMS velocity model used to migrate the input gathers. Must be rectangular (number
ofxlines must be the same for all inlines) and must be indexed in 2D (xline) or 3D (inline, xline)
ETA model: ETA model used to migrate the input gathers. Must be rectangular (number of xlines must be
the same for all inlines) and must be indexed in 2D (xline) or 3D (inline, xline)
Trace Database: For floating datum uses only. The trace.db output from a Tsunami Migration Module that
contains the floating datum statics.
Saved picks: The picks files from a previous RMS and/or ETA picking session. Must be in .xps or .aps
format. If any doubt exists, use the “Convert ASCII file to Semblance Pointset file”
Convert ASCII file to Semblance Pointset file: Used to convert a Promax or .xml picks file to an .aps
compatible format. For more information on usage, see Continue picking with previous picks files

FLOATING DATUM
•
•
•

Seismic/ Velocity at Final: Select if the input migrated gathers and RMS velocity model are both at Final
Datum
Seismic/ Velocity at Float: Select if the input migrated gathers and RMS velocity model are both at
Floating Datum
Reference Velocity: The replacement velocity used for events repositioned to Final Datum. Only needed if
“Seismic/ Velocity at Final” selected.

SEMBLANCE
•
•
•
•

Smoothing window: The number of samples over which to smooth the RMS and/or ETA Semblance
Remove NMO from gathers
Vary by Percent: Stay tuned for future Depth Semblance properties!
Vary by Range:
o RMS Velocity
 Velocity Min: The minimum velocity wanted for the RMS Semblance panel
 Velocity Max: The maximum velocity wanted for the RMS Semblance panel
 Velocity Increment: The velocity sampling used for the RMS Semblance panel. Cannot be
less than 20 [distance/time] units
• Note: (Maximum velocity – Minimum velocity) / Velocity increment = RMS
Step. The RMS step cannot exceed 200.
o ETA Limits
 ETA Min: The minimum ETA wanted for the ETA Semblance panel
 ETA Max The maximum ETA wanted for the RMS Semblance panel
 ETA Increment: The ETA sampling used for the RMS Semblance panel. Cannot be less
than 0.001 units
• Note: (Maximum ETA – Minimum ETA) / ETA increment = ETA Step. The ETA
step cannot exceed 200.

DIMENSIONS
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Inline distance: The inline spacing. Used for RMS/ETA model interpolation.
Xline distance: The xline spacing. Used for RMS/ETA model interpolation.

Semblance Window
LINE OVERLAYS
•
•
•
•
•
•
•
•
•
•

Previous Picks: QC guideline for picks made on an xline to the right of the current gather, on the same
xline.
Previous Picks Properties: Change the line style and color of the Previous Picks QC guideline.
Current Picks: The line drawn to represent picks on the current gather
Current Picks Properties: Change the line style and color of the current picks line
Next Picks: QC guideline for picks made on an xline to the left of the current gather, on the same xline.
Next Picks Properties: Change the line style and color of the Next Picks QC guideline.
Interval Vels: Stay tuned for future Depth Semblance properties!
Interval Vels Properties: Stay tuned for future Depth Semblance properties!
Current Model: QC guideline for the RMS model trace for the current gather. Must have picks selected on
the current gather to see Current Model QC guide.
Current Model Properties: Change the line style and color of the Current Model QC guideline.

GATHER TRAVERSAL
•
•
•
•

Next/Previous Inline: Using the increment set by the display properties at start up, move up or down the
inline by that increment.
Jump to Inline: Jump to a particular inline. Hover over this field to see the dimensions of the INLINE.
Next/Previous Xline: Using the increment set by the display properties at start up, move up or down the
xline by that increment.
Jump to Xline: Jump to a particular xline. Hover over this field to see the dimensions of the XLINE.
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